Author Topic: I experienced an extremely wierd network problem.  (Read 2715 times)

Offline hytparadisee

  • int
  • **
  • Posts: 86
    • View Profile
    • http://peterhi.com
I experienced an extremely wierd network problem.
« on: June 15, 2007, 06:09:51 pm »
My server is on the public internet (so incoming connections should not be a problem.) I use UDP as my protocol. Two clients, one NATed behind a router, the other one doesn't use router but use ADSL dial up. Both clients have firewall turned off. When sending packets to the server, the strangest thing happened. The one NATed can send and receive from the server, but the one exposed to the public cannot.

You may think that it's the problem of firewall still. But let me tell you the much stranger thing. The second client, if wanted to connect, must enable "Internet Connection Sharing" from Control Panel, by that way it works. But as you know, I cannot call each and every one to manually open that because that will give a lot of troubles.

After searching through the notes all i can know is that when "Internet Connection Sharing" enabled, the IP of that computer turned from a end node to a router ip (i.e. 192.168.0.1), by that way the server and this client can work.

Anyone have any experience about it? This problem never happens on Mac i think.

Or in general does anyone have any experience with UDP programming? I don't need the fancy p2p architecture, I can't even make the client-server architecture work. There are always more or less 1 type of computers that cannot interact with the server.
Today I finally found a problem to my soluuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuution

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11776
    • View Profile
    • http://www.jpct.net
Re: I experienced an extremely wierd network problem.
« Reply #1 on: June 18, 2007, 11:18:50 pm »
Does this only happen when using UDP? Or is it the same with TCP?

Offline hytparadisee

  • int
  • **
  • Posts: 86
    • View Profile
    • http://peterhi.com
Re: I experienced an extremely wierd network problem.
« Reply #2 on: June 19, 2007, 05:17:54 am »
Yeah it only happens in udp. And it only happens to the DSL/ISDN dial up connection, I verified it with broadband and it is ok. I haven't checked the telephone line dial up though.
« Last Edit: June 19, 2007, 06:18:12 am by hytparadisee »
Today I finally found a problem to my soluuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuution