Author Topic: Animation -> verbundene polys  (Read 4356 times)

Offline Elrohir

  • byte
  • *
  • Posts: 31
    • View Profile
Animation -> verbundene polys
« on: April 14, 2009, 12:59:40 pm »
Guten abend..
mal wieder habe ich ein kleines problem, betreffend der animation...
Nach dem letzten thread darüber habe ich mich entschieden, mehrere 3ds files für die animation zu machen...
Alles soweit funktioniert, den passenden editor, um die automatisch zusammenzufügen und serialisieren zu lassen, zu schreiben, war kein problem, doch als ich die angefertigte animation dann wieder lud, und sie abspielen wollte, gab es einige merkwürdige darstellungsprobleme...
undzwar verband er scheinbar willkürlich polygone miteinander, die in keiner der keyframes auch nur ansatzweise etwas miteinander zu tun hatten...
Gibt es da irgentwas spezielles, was ich vergessen habe?

lG

Anhang: die 3ds-dateien von der ani..
-> http://upload.worldofplayers.de/files3/womananifluegel.rar

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11769
    • View Profile
    • http://www.jpct.net
Re: Animation -> verbundene polys
« Reply #1 on: April 14, 2009, 01:31:52 pm »
Hast du beim Laden der Ursprungs-3DS-Dateien auch Loader.setVertexOptimization(false); benutzt?

Offline Elrohir

  • byte
  • *
  • Posts: 31
    • View Profile
Re: Animation -> verbundene polys
« Reply #2 on: April 14, 2009, 05:47:42 pm »
Hast du beim Laden der Ursprungs-3DS-Dateien auch Loader.setVertexOptimization(false); benutzt?

Ja, und beim deserialisieren habe ich es ebenfalls gesetzt (obwohl es da ja eigentlich keinen unterschied machen sollte...)
Uh, und falls das wichtig ist: ich hatte es zuerst nur mit den frames bei 0 25 50 75 und 100 probiert, und da war zwar die interpolation nicht zu gebrauchen (deswegen jetzt so viele keyframes (habe die per joint-animation hergestellt)), aber die verbindungen an sich waren, soweit ich das noch in erinnerung habe, in ordnung..

EDIT: ok, habs nochmal mit den paar keyframes probiert... in dem interpolationswirrwarr konnte ich wohl nur nicht so erkennnen, dass es genauso grausig mit den poly-verbindungen umgeht...

EDIT2: hm, das is strange.... habe mir das log noch etwas genauer angesehn, und musste feststellen, dass die polygonanzahl zwar bei allen keyframes die gleiche ist, aber aus irgenteinem grund variiert die anzahl der punkte...
« Last Edit: April 14, 2009, 06:24:52 pm by Elrohir »

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11769
    • View Profile
    • http://www.jpct.net
Re: Animation -> verbundene polys
« Reply #3 on: April 14, 2009, 07:58:33 pm »
EDIT2: hm, das is strange.... habe mir das log noch etwas genauer angesehn, und musste feststellen, dass die polygonanzahl zwar bei allen keyframes die gleiche ist, aber aus irgenteinem grund variiert die anzahl der punkte...
Ja, die Anzahl Punkte schwankt. Das tut sie bei mir schon, wenn ich die einzelnen Modelle in DeepExploration anzeigen lasse. Dann klappt das mit der Interpolation natürlich nicht, weil letztendlich ja Punkte und nicht Polygone interpoliert werden. Du musst irgendwie erreichen, dass die Punktanzahl konstant bleibt. Womit erstellst, bzw. exportierst du die Teile?

Offline Elrohir

  • byte
  • *
  • Posts: 31
    • View Profile
Re: Animation -> verbundene polys
« Reply #4 on: April 14, 2009, 09:40:08 pm »
Ja, die Anzahl Punkte schwankt. Das tut sie bei mir schon, wenn ich die einzelnen Modelle in DeepExploration anzeigen lasse. Dann klappt das mit der Interpolation natürlich nicht, weil letztendlich ja Punkte und nicht Polygone interpoliert werden. Du musst irgendwie erreichen, dass die Punktanzahl konstant bleibt. Womit erstellst, bzw. exportierst du die Teile?

Habe das problem inzwischen gelöst... im 3ds-exporter gab es eine einstellung, dass ab nem bestimmten wert iwi die punkte zusammengeführt werden oder so ähnlich... kaum stellte ich das aus, hat alles funktioniert :)

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11769
    • View Profile
    • http://www.jpct.net
Re: Animation -> verbundene polys
« Reply #5 on: April 14, 2009, 09:52:01 pm »
Aha, super!

Offline Elrohir

  • byte
  • *
  • Posts: 31
    • View Profile
Re: Animation -> verbundene polys
« Reply #6 on: April 14, 2009, 10:02:27 pm »
Aha, super!

Also, falls es dich interessiert, das ganze sieht dann so aus: http://www.thyalae.eu/index.php?mod=downloads&search=video (divX codec von nöten) :) (das erste video... die andern sind übrigens direkt aussem editor aufgenommen, und nicht per jPCT....)