Author Topic: Error using webstart demos  (Read 1729 times)

Offline AW999

  • int
  • **
  • Posts: 57
    • View Profile
Error using webstart demos
« on: February 07, 2010, 04:24:09 am »
I recently got a new computer, and the webstart demos no longer run - apparently lwjgl.dll doesn't work with 64 bit systems.  The applet demos still work fine, however.
 Here's the error log for the Blue Thunder demo:
 ------------------
java.lang.reflect.InvocationTargetException
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
   at java.lang.reflect.Method.invoke(Unknown Source)
   at com.sun.javaws.Launcher.executeApplication(Unknown Source)
   at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
   at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
   at com.sun.javaws.Launcher.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: C:\Users\Allen Williamson\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\13\12c04e0d-2de90f37-n\lwjgl.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(Unknown Source)
   at java.lang.ClassLoader.loadLibrary(Unknown Source)
   at java.lang.Runtime.loadLibrary0(Unknown Source)
   at java.lang.System.loadLibrary(Unknown Source)
   at org.lwjgl.Sys$1.run(Sys.java:75)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:68)
   at org.lwjgl.Sys.loadLibrary(Sys.java:84)
   at org.lwjgl.Sys.<clinit>(Sys.java:101)
   at org.lwjgl.opengl.Display.<clinit>(Display.java:108)
   at com.threed.jpct.GLHelper.findMode(Unknown Source)
   at com.threed.jpct.GLHelper.init(Unknown Source)
   at com.threed.jpct.GLRenderer.init(Unknown Source)
   at com.threed.jpct.FrameBuffer.enableRenderer(Unknown Source)
   at com.threed.jpct.FrameBuffer.enableRenderer(Unknown Source)
   at com.threed.jpct.FrameBuffer.enableRenderer(Unknown Source)
   at com.threed.jpct.demos.bluethunder.BlueThunderRel.initWorld(BlueThunderRel.java:75)
   at com.threed.jpct.demos.bluethunder.BlueThunderRel.main(BlueThunderRel.java:52)
   ... 9 more
 ------------------------

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11747
    • View Profile
    • http://www.jpct.net
Re: Error using webstart demos
« Reply #1 on: February 07, 2010, 09:15:39 pm »
The webstart examples are rather old. The version of LWJGL that i was using back then didn't support 64bit. I should really update them...

Offline AW999

  • int
  • **
  • Posts: 57
    • View Profile
Re: Error using webstart demos
« Reply #2 on: February 07, 2010, 10:49:07 pm »
The webstart examples are rather old. The version of LWJGL that i was using back then didn't support 64bit. I should really update them...

 What about the version of LWJGL included with the development files?  My main concern is the compatibility of my own JPCT-based app once I get it done, since I might do it as a webstart app rather than an applet. 

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11747
    • View Profile
    • http://www.jpct.net
Re: Error using webstart demos
« Reply #3 on: February 08, 2010, 07:22:41 am »
That one includes the 64bit binaries. However, it has a bug with newest ATI Catalyst drivers. You have to wait for LWJGL 2.2.3 to fix this or use the nightly build instead.