Author Topic: "Installation" und erste Anwendung  (Read 2353 times)

Offline AlexReiZ

  • byte
  • *
  • Posts: 2
    • View Profile
"Installation" und erste Anwendung
« on: October 30, 2010, 03:57:25 pm »
Hallo, liebe Community, hallo Egon,

wir haben gestern per youtube.com-Nachricht miteinander geredet. Ich habe mir die verschiedenen Funktionen von jpct einmal angesehen und habe mich dazu entschlossen es zu benutzen.
Ich habe die Dateien heruntergeladen und entpackt.

Mir ist nur nicht klar, wie das mit dem Classpath funktioniert. Ist das eine globale Einstellung für das System oder muss ich das quasi als Parameter eingeben, wenn ich die compilierte Klasse ausführen will?
und wie ich das Ganze unter Eclipse gestallte ist mir auch noch nicht wirklich bewusst. Was ist nötig, um
- Das erste Mal zu Programmieren
- Den Code zu compilieren
- Das Programm zu starten
?

Könnten diese Schritte vielleicht nochmals in einer anderen Form erläutert werden?
Ich bin durch das Tutorial doch schon etwas verwirrt.

Liebe Grüße,

Alex

edit:
Ich habe das Ganze jetzt schon ein wenig besser im Griff, mit dem Texteditor komme ich schon wesentlich weiter. Aber ich arbeite seit langer Zeit mit Eclipse und dabei soll es eigentlich auch bleiben. Kann mir jemand sagen, wie ich Eclipse für JPCT vorbereite?

Ich habe mal ein paar Screenshots gemacht, die ein paar Einstellungen oder Fehler in Eclipse zeigen. Vielleicht fällt euch ja da etwas auf?!




« Last Edit: October 30, 2010, 08:58:43 pm by AlexReiZ »

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11769
    • View Profile
    • http://www.jpct.net
Re: "Installation" und erste Anwendung
« Reply #1 on: November 05, 2010, 11:53:45 pm »
Zeig doch mal den Inhalt des Main-Reiters bei Edit Configuration..."EclipseStarter" sieht mir irgendwie merkwürdig aus...

Edit: Und Sorry für die späte Antwort...ist irgendwie im Stress der letzten Tage untergegangen... :(
« Last Edit: November 05, 2010, 11:55:20 pm by EgonOlsen »

Offline AlexReiZ

  • byte
  • *
  • Posts: 2
    • View Profile
Re: "Installation" und erste Anwendung
« Reply #2 on: December 27, 2010, 05:15:08 pm »
Hier ist der Main-Reiter. Scheint mir nicht fertig configuriert zu sein. Beziehungsweise garnicht mehr configuriert. Ich habe mich damit ne Weile nicht mehr beschäftigt....



Ich hoffe, dass sich da eine Lösung finden lässt ;)

MFG,

Alex

Offline Miridian

  • byte
  • *
  • Posts: 15
    • View Profile
    • My Blog :)
Re: "Installation" und erste Anwendung
« Reply #3 on: January 04, 2011, 11:40:34 pm »
Den Fehler hatte ich auch.
Habe die Lösung hier gefunden http://www.lwjgl.org/wiki/index.php?title=Setting_Up_LWJGL_with_Eclipse


Finally we need to setup the native component of LWJGL. This is done by clicking the little arrow next to the lwjgl.jar file to show the drop down list. Double click 'Native library location' and select the folder that contains the native files for your operating system and clicking OK.

Da habe ich dann einfach C:\ eingetragen, was sicherlich nicht richtig ist, aber es läuft. :D

Ich weiss nicht genau was mit "folder that contains the native files" gemeint ist ???
Hoffe jemand kann uns da weiterhelfen.

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11769
    • View Profile
    • http://www.jpct.net
Re: "Installation" und erste Anwendung
« Reply #4 on: January 06, 2011, 12:40:13 pm »
"folder that contains the native files" meint das Verzeichnis mit den DLLs (für Windows) oder SOs (für Linux) oder was halt die eigene Maschine so verwendet. So ganz grob steht das auch im jPCT-Wiki beschrieben, aber leider ohne Bilder...