Author Topic: Model in the app looks different from what is seen in Maya  (Read 5733 times)

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Model in the app looks different from what is seen in Maya
« on: July 01, 2011, 09:35:49 am »
hi raft,
I am seeing a difference between the way the model is displayed in my app (which used NinjaDemo as the base) and the way model is displayed in Maya.  The model looks OK when viewed in Maya. 
But in the Android Emulator and the Samsung Android device, the center of the model looks like it has been pulled closer to the camera.  As a result the center portions of the model looks larger and the portion away from the center are looking smaller; which actually doesn't look good.
I tried manipulating 'cameratarget.y'.  But it didn't help.   :(
I've mailed you the screenshots from Maya and Android Emulator (couldn't attach in the post due to size restriction).Can you please help me identifying the root cause?

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Model in the app looks different from what is seen in Maya
« Reply #1 on: July 01, 2011, 12:21:24 pm »
how does it look in desktop samples?

looking at your screenshots, seems as camera is looking up from a low position. Ninja app places camera such that camera looks horizontally so I assume you have changed something else

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #2 on: July 01, 2011, 12:30:32 pm »
I don't build the desktop samples  :(
ok.. I'll check if I have changed anything from the NinjaDemo.. and then get back to you...

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #3 on: July 01, 2011, 04:41:04 pm »
I needed only one model in the center of the screen.
So the only difference between the ninja-demo and my app is that, I've commented out "ninja.getRoot().translate" in the function, addNinja().

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Model in the app looks different from what is seen in Maya
« Reply #4 on: July 01, 2011, 06:12:25 pm »
well, your screenshot definetely suggests camera is somehow looking up. maybe you had changed CameraOrbitController which actually places camera.

try printing camera direction every frame, if i'm right its y value should be none zero.

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #5 on: July 02, 2011, 08:10:07 am »
I didn't change anything in CameraOrbitController.
However, I used Camera.getDirection() to get the direction and then print it.  But still the 'y' is zero.  :o
Code: [Select]
AMSRenderer(2858): <onDrawFrame> Camera's Direction=(0.0,0.0,-1.0)
I am attaching the CameraOrbitController that I am using...  :-\



[attachment deleted by admin]

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Model in the app looks different from what is seen in Maya
« Reply #6 on: July 02, 2011, 04:34:03 pm »
that's strange ::) although i stil think this cant be related to model or bones, send me your model please and let me have a look.

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #7 on: July 02, 2011, 05:31:32 pm »
thanks a lot, raft.  :-[
I have mailed you the drop from my artist.  Feel free to let me know if you require anything else.

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Model in the app looks different from what is seen in Maya
« Reply #8 on: July 02, 2011, 05:48:59 pm »
this is how your model looks in desktop sample. seems right to me:



maybe you are rotating your model while converting it to Bones' native format?

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #9 on: July 02, 2011, 06:58:58 pm »
yeah, the model was loading upside down.  So I am using -rotation z180 to get it straight...
Is there a way out?  :(

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #10 on: July 02, 2011, 07:15:44 pm »
even if I don't rotate, i.e. even when it's loaded upside down, the same issue is observed... pls. find attached the screenshot... :-\

[attachment deleted by admin]

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Model in the app looks different from what is seen in Maya
« Reply #11 on: July 02, 2011, 07:38:40 pm »
i'm afraid i'm losing track here ::) the last render you had sent is the same as desktop render which you approved correct. and it's different from the first one you had sent me via email. i dont see the problem with this last one. my test looks the same too  :-\


Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #12 on: July 02, 2011, 08:20:47 pm »
IMHO, they're different.  I am attaching the screenshot for the rotated model with the background color for easy comparison.
Specifically,
Your screen shot: Eyes are straight; mine: eyes are looking down
your screen shot: Front of nose is visible; mine: bottom of the nose is visible
Your screen shot: Smile is visible; mine: smile is not visible
Your screen shot: Has more space above eye-brow(basically, the forehead is fully visible); mine: forehead is not fully visible...

however, not sure if you see the same way  :-\

[attachment deleted by admin]

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Model in the app looks different from what is seen in Maya
« Reply #13 on: July 02, 2011, 08:30:32 pm »
mm, you are right, i haven't noticed these differences when the model is upside down ::)

but returning to subject, i didnt do anything special. just converted your model to Bones' native format with a z rotation of 180 degrees. commented out ninja.getRoot().translate(..) as you did and got this view :-\ this is not emulator but Nexus One but that shouldnt make a difference :-\

why dont you redownload the Ninja demo app and start from scratch..

Offline Babu

  • int
  • **
  • Posts: 71
    • View Profile
Re: Model in the app looks different from what is seen in Maya
« Reply #14 on: July 02, 2011, 08:40:34 pm »
unfortunately, I am seeing the same problem even with Samsung Galaxy 3 (just confirm that is not diff b/w phone and emulator).
Yeah, ok, I will start from the scratch  :(... and then get back to you...

thanks a lot for the continuos support, raft...