Author Topic: Low performance question  (Read 1419 times)

Offline ukrteam

  • byte
  • *
  • Posts: 1
    • View Profile
Low performance question
« on: August 20, 2011, 03:59:43 pm »
Hi!
I have a question about jPCT-AE performance. I have create a simple application to test your engine performance - I put 9 models. In single model there were 7707 verticles quantity and 4514 faces. Running this test on HTC Desire HD I got 17-20 fps. Please, tell me if this low fps normal for jPCT-AE? And is it possible to improve performance?
Thx for your answer!

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11749
    • View Profile
    • http://www.jpct.net
Re: Low performance question
« Reply #1 on: August 21, 2011, 10:38:50 am »
It's not normal for the engine, it's normal for what you are doing. Always consider that you are on a mobile, low power device. You are rendering around 70,000 vertices/40,000 polygons per frame, which isn't that much but it's not really low polygon either.

However, you can try a few things to speed it up:


Offline Alexey

  • int
  • **
  • Posts: 50
    • View Profile
Re: Low performance question
« Reply #2 on: August 29, 2011, 11:32:34 am »
What would not create a new topic, ask here - for example, some objects in camera focus, camera should rotate around its,  for performance better rotate camera or objects? or a small difference?

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11749
    • View Profile
    • http://www.jpct.net
Re: Low performance question
« Reply #3 on: August 29, 2011, 12:11:08 pm »
There's no difference between these two approaches. In the end, it all comes down to a transformation matrix/object