Author Topic: Animation Blending isn't working.  (Read 4704 times)

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Animation Blending isn't working.
« Reply #15 on: September 11, 2011, 10:26:04 pm »
i don't have an exporter ;)

OgreMax has a setting to control how many keframes are exported

Offline AGP

  • quad
  • ******
  • Posts: 1526
    • View Profile
Re: Animation Blending isn't working.
« Reply #16 on: September 11, 2011, 10:31:32 pm »
Yes you do: ogre-bones.

Do you mean the "optimize skeleton animation" setting? But still, the result shouldn't be choppy, just weird.

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Animation Blending isn't working.
« Reply #17 on: September 11, 2011, 10:40:38 pm »
no I don't. It's just a transformation of format. No keyframes vertices etc. is modified in process.

I can't remember the exact setting but it must be something like keyframes per second

Offline AGP

  • quad
  • ******
  • Posts: 1526
    • View Profile
Re: Animation Blending isn't working.
« Reply #18 on: September 11, 2011, 10:54:23 pm »
It's still a proprietary format. I speak English and this is a semantics discussion. I say exporter, you say something else. We're both talking about the same thing.

I'll check. If I find something of the sort I will add to the wiki.

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1973
    • View Profile
    • http://www.aptalkarga.com
Re: Animation Blending isn't working.
« Reply #19 on: September 11, 2011, 11:48:43 pm »
I agree that it's a semantics issue. But my point is Bones does not change any structure. You get what you export

Offline AGP

  • quad
  • ******
  • Posts: 1526
    • View Profile
Re: Animation Blending isn't working.
« Reply #20 on: September 26, 2011, 07:35:12 am »
For whatever it's worth, I couldn't get it to run smoothly at 40+ fps. Setting OgreMax to 30 fps may have helped a little (I'm not sure), but perfect it isn't. And at 40+ frames per second, it should look smooth.