Author Topic: Help! - all I get is a black triangle  (Read 5048 times)

Offline adrian_roney

  • byte
  • *
  • Posts: 11
    • View Profile
Re: Help! - all I get is a black triangle
« Reply #15 on: October 16, 2011, 10:26:48 pm »
ok again,

sorry for being a newbie..

how do I get the model file to you?


Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11748
    • View Profile
    • http://www.jpct.net
Re: Help! - all I get is a black triangle
« Reply #16 on: October 16, 2011, 10:27:10 pm »
Try to send it to info@jpct.net

BTW: I've edited your log output to use code-tags, so that it's actually readable on a mobile device... ;)

Offline adrian_roney

  • byte
  • *
  • Posts: 11
    • View Profile
Re: Help! - all I get is a black triangle
« Reply #17 on: October 16, 2011, 10:45:48 pm »
again sorry....  :-[

Emailing a zip with the 3ds file and the textures in it.


Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11748
    • View Profile
    • http://www.jpct.net
Re: Help! - all I get is a black triangle
« Reply #18 on: October 16, 2011, 11:45:25 pm »
I've emailed you some files...there are several problems with this particular file. The model is a ship at a reasonable size placed on a kind of "ocean" at a ludicrous size with culling inversed. The result is that with your default camera placement, you were looking at the ship from below and because the culling of the "ocean" is reversed, all you see is the ocean (from below...). But even that fails, because the polygons are so huge that the PowerVR GPU in your device can't render it properly. In addition, the color format for diffuse colors in this file is strange (the loader detects this and prints out a warning but the setting it refers to isn't available in 1.25...i'll add it to the next version). I solved this by loading the model in DeepExploration and saving it again as 3ds, which fixed the colors.

So for now, i've modified the 3ds file to fix the color problem and changed the setup code for the camera to look at the ship from the other side. The ocean isn't visible now, but that doesn't hurt as it can't be rendered properly anyway.

BTW: One of the texture files had a 80*80 format. You should change that to something like 64*64...or maybe you already have, because otherwise jPCT-AE wouldn't load it.

A screen shot to show that it actually does something:




Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11748
    • View Profile
    • http://www.jpct.net
Re: Help! - all I get is a black triangle
« Reply #19 on: October 16, 2011, 11:51:37 pm »
BTW: Complex models from model sites are a common source for all kinds of trouble. Most of them haven't been created with real-time rendering in mind, so they tend to be overly complex, their culling is often wrong and their scaling is often funny. Just keep that in mind when working with them.

Offline adrian_roney

  • byte
  • *
  • Posts: 11
    • View Profile
Re: Help! - all I get is a black triangle
« Reply #20 on: October 17, 2011, 12:06:10 am »
wow..

absolutely awesome!

Thank you so much for spending so much of your Sunday evening with me!.

I clearly have an awful lot to learn in this space.

Thanks again!

Adrian.