Author Topic: strange malfunction  (Read 2446 times)

Offline Melssj5

  • double
  • *****
  • Posts: 715
    • View Profile
strange malfunction
« on: February 15, 2005, 08:45:23 am »
Hello, I made a program, not a game, just for my University, about a mouse inside a maze that must find the chesse. So it worked perfectly so I made a 3D aplication for that, and it worked the mouse moved along the maze by it self, but when I tried to set a camara in front of the mouse, the mouse doesnt rotate, only move, just for changing the camera, that have nothing to do with the object called "Rat".

Another problem but this is not strange, when I move the rat, The mobement is not continuous. it moves like a teletransportation and not like a movement like walking, is just about moving with a slow speed?

by the way someone have a rat model .3ds  U can use, vecausse as long as its very difficult to do a rat using 3D sturio max, I used an airplane  :oops:
Nada por ahora

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11745
    • View Profile
    • http://www.jpct.net
strange malfunction
« Reply #1 on: February 15, 2005, 10:21:00 am »
Quote
So it worked perfectly so I made a 3D aplication for that, and it worked the mouse moved along the maze by it self, but when I tried to set a camara in front of the mouse, the mouse doesnt rotate, only move, just for changing the camera, that have nothing to do with the object called "Rat".


What do you mean exactly? Does it run into the walls of the maze instead? I can't see a relationship between your object (mouse/airplane/whatever) and the camera unless you are doing something strange in your attempt to allow multiple cameras in one world but different applets. Maybe a code snippet world help that shows how you are setting up the camera and moving your mouse and the camera.


Quote
Another problem but this is not strange, when I move the rat, The mobement is not continuous. it moves like a teletransportation and not like a movement like walking, is just about moving with a slow speed?


If you do a translation like (10,0,0), it will of course jump from its current position to current.x+10. If you want to happen this smooth, you have to interpolate it yourself (for example by moving one unit per frame instead of 10 until you've reached your destination).

Anonymous

  • Guest
strange malfunction
« Reply #2 on: February 15, 2005, 03:59:27 pm »
Quote from: "EgonOlsen"


What do you mean exactly? Does it run into the walls of the maze instead? I can't see a relationship between your object (mouse/airplane/whatever) and the camera unless you are doing something strange in your attempt to allow multiple cameras in one world but different applets. Maybe a code snippet world help that shows how you are setting up the camera and moving your mouse and the camera.



I have an object3D called Rat. it moves but it doesnt rotate when I use the another camera, I mean that the rat moves to left, front, back, right, as it should do, but when using the second camera, it doesnt rotate

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11745
    • View Profile
    • http://www.jpct.net
strange malfunction
« Reply #3 on: February 15, 2005, 08:22:42 pm »
It must be something you are doing. Concerning jPCT's inner workings, there's absolutly no relationship between an objects rotation and the camera...unless you are creating one somehow.
The only thing i can imagine is that something gets confused by your multi-applet-one-world-different-cameras-approach, but even then...i can't think of anything that will cause this.
By "second camera" you mean "second applet", don't you? If you do, i assume that it doesn't rotate correctly in any of them, right? Or is it ok in one and wrong in the other?