Author Topic: Problem while converting skeleton to xml  (Read 1454 times)

Offline subhalakshmi27

  • byte
  • *
  • Posts: 21
    • View Profile
Problem while converting skeleton to xml
« on: May 08, 2012, 07:09:40 pm »
Hi,

I am getting following error while converting the skeleton file to xml,

lod levels       = none (or use existing)
Generate edge lists  = 1
Generate tangents = 0
 semantic = TANGENT
 parity = 0
 split mirror = 0
 split rotated = 0
Reorganise vertex buffers = 1
Optimise animations = 1
-- END OPTIONS --

Creating resource group General
Creating resource group Internal
Creating resource group Autodetect
Registering ResourceManager for type Mesh
Registering ResourceManager for type Material
Registering ResourceManager for type Skeleton
Exception caught: A bone with the handle 1 already existsUnregistering ResourceM
anager for type Skeleton
Unregistering ResourceManager for type Material
Unregistering ResourceManager for type Mesh


Please let me know when this error can occur ?

Regards,
Subha
« Last Edit: May 08, 2012, 08:34:22 pm by subhalakshmi27 »

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1966
    • View Profile
    • http://www.aptalkarga.com
Re: Problem while converting skeleton to xml
« Reply #1 on: May 09, 2012, 08:43:01 am »
I've no idea. maybe exporter and xml convertor versions mismatch? try asking in Ogre forums

Offline subhalakshmi27

  • byte
  • *
  • Posts: 21
    • View Profile
Re: Problem while converting skeleton to xml
« Reply #2 on: May 17, 2012, 07:01:12 am »
Hi raft,

I asked in ogre forum, there is a patch for this issue. I have to apply the patch and create new batch file for converting ogre file to xml file. Thanks for your help.

Regards,
Subha

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1966
    • View Profile
    • http://www.aptalkarga.com
Re: Problem while converting skeleton to xml
« Reply #3 on: May 17, 2012, 01:00:46 pm »
cool, I'm glad that you had progress on this issue :)