Author Topic: Animaiton in the app looks different from what is seen in Maya  (Read 1646 times)

Offline kiffa

  • long
  • ***
  • Posts: 199
    • View Profile
I made an animation of a dog. When playing the animation, the dog's head will move up and down.

Everything seems ok in maya. The dog has two ears, when his head move up, both of his ears should move up too, but on my phone, one of his ear moves up, the other seems like moving down......

maya2012 + OgreMax.

I have checked the .skeleton.xml, but i don't know if they are correct. Here are the track info:

left ear(correct-moving ear):

 <track bone="joint34">
                    <keyframes>
                        <keyframe time="0">
                            <translate x="0" y="0" z="0" />
                            <rotate angle="0">
                                <axis x="1" y="0" z="0" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.239583">
                            <translate x="0" y="1.7112" z="-6.31536" />
                            <rotate angle="0.602536">
                                <axis x="1.37439e-008" y="0.982929" z="-0.183988" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.479167">
                            <translate x="0" y="0.0458412" z="-11.6619" />
                            <rotate angle="1.10437">
                                <axis x="-1.12722e-008" y="0.93108" z="-0.364815" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.71875">
                            <translate x="0" y="1.7174" z="-5.50479" />
                            <rotate angle="0.529574">
                                <axis x="9.25609e-009" y="0.987027" z="-0.160556" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.958333">
                            <translate x="0" y="0" z="0" />
                            <rotate angle="0">
                                <axis x="1" y="0" z="0" />
                            </rotate>
                        </keyframe>
                    </keyframes>
                </track>


right ear(wrong-moving ear):

     <track bone="joint38">
                    <keyframes>
                        <keyframe time="0">
                            <translate x="0" y="0" z="0" />
                            <rotate angle="0">
                                <axis x="1" y="0" z="0" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.239583">
                            <translate x="0" y="1.7112" z="-6.31536" />
                            <rotate angle="5.68065">
                                <axis x="1.37439e-008" y="0.982929" z="0.183988" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.479167">
                            <translate x="0" y="0.0458412" z="-11.6619" />
                            <rotate angle="5.17882">
                                <axis x="-1.12722e-008" y="0.93108" z="0.364815" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.71875">
                            <translate x="0" y="1.7174" z="-5.50479" />
                            <rotate angle="5.75361">
                                <axis x="9.25608e-009" y="0.987027" z="0.160556" />
                            </rotate>
                        </keyframe>
                        <keyframe time="0.958333">
                            <translate x="0" y="0" z="0" />
                            <rotate angle="0">
                                <axis x="1" y="0" z="0" />
                            </rotate>
                        </keyframe>
                    </keyframes>
                </track>







Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1972
    • View Profile
    • http://www.aptalkarga.com
Re: Animaiton in the app looks different from what is seen in Maya
« Reply #1 on: July 24, 2012, 01:38:57 pm »
well, Bones play animation what is exported by exporter. there is no such possibility that some part of animation is played ok but other part is not. in short, what you see is what exporter exported ;)

Offline kiffa

  • long
  • ***
  • Posts: 199
    • View Profile
Re: Animaiton in the app looks different from what is seen in Maya
« Reply #2 on: July 25, 2012, 04:39:54 am »
My artist has fixed this ;D, thanks!

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1972
    • View Profile
    • http://www.aptalkarga.com
Re: Animaiton in the app looks different from what is seen in Maya
« Reply #3 on: July 25, 2012, 05:13:47 am »
cool, I'm glad you had fixed that ;)

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1972
    • View Profile
    • http://www.aptalkarga.com
Re: Animaiton in the app looks different from what is seen in Maya
« Reply #4 on: July 25, 2012, 05:37:49 am »
and for the records, how exactly your artist solved that? may help other Maya users

Offline kiffa

  • long
  • ***
  • Posts: 199
    • View Profile
Re: Animaiton in the app looks different from what is seen in Maya
« Reply #5 on: July 25, 2012, 09:25:56 am »
Just clear some useless maya-historys. ;)