Author Topic: question about transparency...  (Read 703 times)

Offline jordi

  • byte
  • *
  • Posts: 2
    • View Profile
question about transparency...
« on: November 13, 2013, 04:08:49 pm »
hi, i'm a beginner with jPCT and i'm having problems dealing with transparency:

I want to load a .obj model i made with wings3d. The texture simulates a "wireframe" and the model has a "vertical hole" on the geometry. So, it should be possible to see the wires of the back of the figure behind the transparent texture.

On the attached image it can be seen the model on wings3d, with a "wire" from the back visible behind the transparent textured polygon on the front. (marked in red)

But when loaded in my project the wires from the back are hidden behind the transparent texture (also shown on the attachment marked in red).

Any ideas why is that happening and how to correct it?

i'm not sure if this has anything to do with it or not but here is some code related to transparency i'm using:
(i did that to get transparent background)
      
      mGLView = (GLSurfaceView) findViewById(R.id.surface_view);
      mGLView.setEGLConfigChooser(8, 8, 8, 8, 16, 0);
      mGLView.getHolder().setFormat(PixelFormat.TRANSLUCENT);



any ideas?

[attachment deleted by admin]

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11748
    • View Profile
    • http://www.jpct.net
Re: question about transparency...
« Reply #1 on: November 13, 2013, 10:01:15 pm »
Transparency has been enabled for the object (Object3D.setTransparency([0..]); )?

Offline jordi

  • byte
  • *
  • Posts: 2
    • View Profile
Re: question about transparency...
« Reply #2 on: November 14, 2013, 10:19:14 am »
ah, that was it!
had to be something like that :)

thanks