Author Topic: Texture UVMapping  (Read 914 times)

Offline sushobhit

  • long
  • ***
  • Posts: 109
  • future is now
    • View Profile
    • ANDROID APPS
Texture UVMapping
« on: March 10, 2014, 10:33:47 am »
Just trying to make an Island model.
The Model loads perfectly (format .md2)
Created the Texture Map for the Model in UVMapping Software (Steve Cox)

I choose Planar Map , it creates the front and the back
But when I settexture in JPCT the texture are very qurky

Tried to create tile texture by group but still the texture are not at all applied properly.

What I want to know is what are the specifications for creating the Texture Map of an Model :
Which software should be used.
The Model was created in Milkshape3d then I exported it to MD2.
To create the Texture I exported the model .OBJ and opened it in UVMapper (Steve Cox)
-> New UV Map
Alignment Z-Axis
Split By Orientation
Orientation Horizontal

But the texturemap it creates does not at all orients with the model in the JPCT
What happens is simply the whole Bitmap is pasted on the Model

What could be the problem...
I have also tried it with calctexturewrap but to no use

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11748
    • View Profile
    • http://www.jpct.net
Re: Texture UVMapping
« Reply #1 on: March 10, 2014, 08:09:43 pm »
This can have several reasons:

  • The texture is upside-down. Some md2 exporters seem to flip the texture. Try if it helps to flip it back.
  • Your texture coordinates don't make it into the file. Check your exporter's settings.
  • You still have a call to either calcTextureWrap or calcTextureWrapSpherical in your code. If so, remove it. These methods aren't meant to be used on models that provide their own coordinates.

Offline sushobhit

  • long
  • ***
  • Posts: 109
  • future is now
    • View Profile
    • ANDROID APPS
Re: Texture UVMapping
« Reply #2 on: March 11, 2014, 07:12:46 am »
Can you take a look at what is wrong :

Model : http://speedy.sh/k56R3/myboy.md2

Texture Map : http://speedy.sh/txmSD/THISSHOULDDO.bmp

Offline sushobhit

  • long
  • ***
  • Posts: 109
  • future is now
    • View Profile
    • ANDROID APPS
Re: Texture UVMapping
« Reply #3 on: March 11, 2014, 07:28:24 am »
And this is how I am filling the colors in the MAP :

Just a rough MAP i create in MSPAINT (just to test) :

http://speedy.sh/hr42P/THISSHOULDDO.bmp

When I get it right it would be photoshopped
This one is just to explain what I am doing...

Please point out where I am going wrong because this is the last problem I am encountering rest all the concepts have come into place...

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11748
    • View Profile
    • http://www.jpct.net
Re: Texture UVMapping
« Reply #4 on: March 11, 2014, 08:56:37 am »
Something seems to be wrong with your exporter. I tried to load it in two other programs and they both apply the texture just like jPCT does, i.e. wrong.

Offline sushobhit

  • long
  • ***
  • Posts: 109
  • future is now
    • View Profile
    • ANDROID APPS
Re: Texture UVMapping
« Reply #5 on: March 11, 2014, 10:38:18 am »
thanks got it

I was not putting the UV's on the model before exporting that is why they were not getting applied..

Used lithUnWrap to make the map.
Exported .luv
Exported .bmp

Applied .luv on my .ms3d and then exported
painted .bmp with skin . and there it was MYBOY with clothes on ;)