Author Topic: [ resolved ] render some complex animated model via Bones  (Read 691 times)

Offline cefengxu

  • int
  • **
  • Posts: 65
    • View Profile
[ resolved ] render some complex animated model via Bones
« on: November 23, 2015, 10:15:37 am »
hi  raft :

now i can create some simple model ( teapot , cube and et al ..  ), add some bones and animated  and export to .bones , and then render via bones successfully.

however, when i render some complex model ( or download from the internet  ), the result is : the screen shows nothing.
oppositely , i can export this model into obj and render via jPCT-AE successfully.

i am sure the "Steps of .Bones Export" is correctly and the code is ran  certainly according the logcat


so , do you meet such bug ??? or may be the Bones could no render some complex model with animation ?

Rgs

Cefengxu
« Last Edit: November 26, 2015, 05:00:46 pm by cefengxu »

Offline raft

  • Moderator
  • quad
  • *****
  • Posts: 1966
    • View Profile
    • http://www.aptalkarga.com
Re: [ resolving ] render some complex animated model via Bones
« Reply #1 on: November 25, 2015, 09:42:39 am »
sorry for late response. did you try your model in OgreSample? with mouse scroll you can zoom in/out and check where your model actually is.

Offline cefengxu

  • int
  • **
  • Posts: 65
    • View Profile
Re: [ resolving ] render some complex animated model via Bones
« Reply #2 on: November 26, 2015, 05:00:22 pm »
i know what's going on~ because the model is too complicated and too many vertexs.
so i used meshlab to reduce the vertexs and then the Bones can render it ~!

thanks ~