Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - cathal

Pages: [1]
Bones / Re: Frame rate with Blender export
« on: February 26, 2012, 06:18:51 pm »
Oh, my blurry reference: it is the Ogre exporter.

I have checked the Ogre forums. The suggestion is that Blender has the extra vertices, uses them in rendering and so on, but doesn't include them in the displayed count. The extra vertices are used to give correct texturing and lighting. So for a cube there would be 24 vertices (three for each mesh vertex) to generate three normals for each (mesh) vertex. Fine. But I have a pretty smooth mesh, so I'd like to be able to control fully the generation of extra vertices.  ???

I thought I'd mention it here in case someone is wondering why their frame rate is so low...

Bones / Frame rate with Blender export
« on: February 26, 2012, 12:53:30 am »

First of all: thanks for the great work on the engine!

I have been using the jME Blender to Ogre exporter to produce mesh/skeleton .xml, then using the script to convert to .bones. Thanks to efaj and raft's instructions, it all works well.

But there is an issue (feature? problem?) with the jME exporter which can seriously compromise the frame rate. For example, on a (low-end) HTC, the ninja demo runs at about 50fps. I exported a model which has a similar vertex/face count, but it runs at <25fps.

It seems that the jME exporter adds vertices where there's a sharp normal, or colour change; a model that had 506 vertices before export became a model with 2036 vertices after export.

The only way I have found to eliminate the addition of vertices is by switching on smooth shading (Object Tools - LH window) and not using a UV map/texture. When I add a map and texture, the exporter increases the vertex count by 50%. Better, but still really annoying.

Does anyone know how to stop the jME exporter from adding vertices? (I've tried all of the export options and nothing works.)

Pages: [1]