Author Topic: glfullscreen false question. *resolved  (Read 1486 times)

Offline Disastorm

  • long
  • ***
  • Posts: 161
    • View Profile
glfullscreen false question. *resolved
« on: June 13, 2011, 05:13:16 am »
Hello, I noticed that if I have glfullscreen set to false my game lags quite a bit but when i set it to fullscreen it is perfectly smooth.  Is this normal?  This started happening when i tried to add in a mirror which is basically an object that has a camera that renders to the object's texture.
« Last Edit: June 14, 2011, 09:00:49 am by Disastorm »

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11968
    • View Profile
    • http://www.jpct.net
Re: glfullscreen false question.
« Reply #1 on: June 13, 2011, 08:28:16 pm »
Depending on the driver/OS/hardware, windowed mode can be slower than fullscreen. Do you have some frame rate numbers for both modes?

Offline Disastorm

  • long
  • ***
  • Posts: 161
    • View Profile
Re: glfullscreen false question.
« Reply #2 on: June 13, 2011, 10:52:20 pm »
i think the frame rate is the same when its not lagging.  It starts lagging as soon as i walk in range of the second camera which is rendering to the texture.  Like almost freezes less than 1 fps.  Im on Windows 7 64 bit and using a Radeon HD 5870.  Im not entirely sure when it started happening I used to have a sphere that had texture rendered from the same camera as the display in windowed mode (only had 1 camera at this time) and it didn't lag at all, but then i started testing stuff in fullscreen and didn't realize that at some point, my windowed mode got messed up.  

However, I noticed if I removed some of the objects in my world the lag vanished.  Alternatively, if I ended the windows process svchost (it was using 200mb of memory), the lag would basically dissapear as well until svchost was automatically started back up.  Not sure why that happens, I did notice that when svc host is terminated, the start menu bar on Windows 7 becomes a solid color instead of being transparent so I dunno if thats related to anything.
« Last Edit: June 13, 2011, 11:02:18 pm by Disastorm »

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11968
    • View Profile
    • http://www.jpct.net
Re: glfullscreen false question.
« Reply #3 on: June 13, 2011, 11:16:01 pm »
Looks like as if Windows disables Aero (the taskbar changing color is an indicator for this). Actually, this shouldn't happen but there's nothing i can do about it. It's either a driver or a LWJGL problem. You might want to try the latest version of LWJGL, in case that you haven't done that already.

Offline Disastorm

  • long
  • ***
  • Posts: 161
    • View Profile
Re: glfullscreen false question.
« Reply #4 on: June 14, 2011, 12:30:58 am »
*edit: it turns out i was already using the most recent version of lwjgl but not jpct.  Upgrading JPCT from 1.21 to 1.23 actually fixed the problem.  Good job on your updates!  I did confirm that Aero was what was messing up the 1.21 jpct's windowed mode, but it looks like you fixed that.
« Last Edit: June 14, 2011, 08:52:55 am by Disastorm »

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11968
    • View Profile
    • http://www.jpct.net
Re: glfullscreen false question. *resolved
« Reply #5 on: June 14, 2011, 05:38:03 pm »
I'm not aware of any changes between those versions, that would explain this, but if all is fine now... ;D