Author Topic: Billboarded Planes And Overlay Issues  (Read 1012 times)

Offline AGP

  • quad
  • ******
  • Posts: 1616
    • View Profile
Billboarded Planes And Overlay Issues
« on: December 20, 2011, 07:38:10 pm »
I've noticed that on too many video cards, billboarded planes don't work (my animated GIFs come off as black and white for some reason), with both the software or hardware renderer. Also, most of those times the Overlay with TRANSPARENCY_MODE_DEFAULT doesn't work either. Has anybody else complained?

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 11970
    • View Profile
    • http://www.jpct.net
Re: Billboarded Planes And Overlay Issues
« Reply #1 on: December 20, 2011, 08:19:35 pm »
No. never heard of this. And it doesn't make much sense either, because bill boarding has nothing to do with the GPU. It's just simple matrix operation. If it doesn't work with the software renderer either, it's more likely an issue with loading the gifs than anything else.... ???

Offline AGP

  • quad
  • ******
  • Posts: 1616
    • View Profile
Re: Billboarded Planes And Overlay Issues
« Reply #2 on: December 20, 2011, 09:08:11 pm »
That doesn't make any sense. Java's GIF loader has been around for a very long time.

Offline AGP

  • quad
  • ******
  • Posts: 1616
    • View Profile
Re: Billboarded Planes And Overlay Issues
« Reply #3 on: December 20, 2011, 09:32:49 pm »
About the Overlay: something must have changed with BufferedImage. Whereas before, initializing one with TYPE_INT_RGB created a black image, this time around it was creating a white one. INT_ARGB solved it for me. But the GIF on billboarded planes thing remains. And it's only on certain computers.

Update: Looking at the code I noticed it's using BufferedImage, so I'm wondering if this also isn't related to changes in BufferedImage's behaviour. I'll post back when I know.
« Last Edit: December 20, 2011, 10:11:39 pm by AGP »