Author Topic: Texture artifacts (green/purple/black)  (Read 898 times)

Offline ap

  • byte
  • *
  • Posts: 12
    • View Profile
Texture artifacts (green/purple/black)
« on: May 10, 2015, 02:08:21 pm »
Hello

I am trying to play a video on a 3D object.
I am streaming the video (with Android's MediaPlayer) into a texture (through SurfaceTexture and Surface), and then map this texture to a plane. It works, but I get weird artifacts on the borders (looks like a green and black checkerboard and sometimes it blinks green and purple).
It seems to be something with the GPU (PowerVR), but I guess there should be a way to solve this... I am still now sure what it is.

Anyone got that or have any idea how to solve a thing like that?

Thanks
AP

Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 12048
    • View Profile
    • http://www.jpct.net
Re: Texture artifacts (green/purple/black)
« Reply #1 on: May 10, 2015, 02:32:53 pm »
Do you have a screen shot?

Offline ap

  • byte
  • *
  • Posts: 12
    • View Profile
Re: Texture artifacts (green/purple/black)
« Reply #2 on: May 10, 2015, 03:33:54 pm »
Yes.
That's a video "projected" on a plane.

At first I thought maybe it's aspect ratio issue - it wasn't.
Then I thought, maybe something to do with texture wrapping  or texture filtering - neither.
Tried on two devices with PowerVR GPU - same result. Another device with another GPU - worked perfectly.


Offline EgonOlsen

  • Administrator
  • quad
  • *****
  • Posts: 12048
    • View Profile
    • http://www.jpct.net
Re: Texture artifacts (green/purple/black)
« Reply #3 on: May 10, 2015, 05:51:36 pm »
Maybe it has something to do with video size/aspect ratio compared to the texture's? Maybe the PowerVR video processor can apply certain scales only or something like this...I've no idea, I'm just guessing...