Requirements

From JPCT
Revision as of 22:02, 3 April 2009 by Admin (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

jPCT uses Java. To develop application using jPCT you need at least the Java Development Kit (JDK). For more comfort, you may want to use an IDE such as Eclipse or Netbeans.

jPCT is compatible to java 1.1 but some features can only be used with higher version. The current version of Java is Java6, which is recommended to be used with jPCT. If you are for some reason stuck to Java 1.4 or Java5, don't worry...jPCT will work fine with both of them.

jPCT offer a Java 1.1 compatible software renderer and two OpenGL based hardware renderers. The hardware renderers are based on LWJGL and support Windows, Linux x86, Mac OSX and Solaris.