Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - dectar

Pages: [1] 2
Support / Re: Lensflare help
« on: November 22, 2011, 12:20:00 pm »
I managed to create my own lensflare images that are relatively believable so I should be ok with these. Thanks again

Support / Re: Lensflare help
« on: November 21, 2011, 11:05:59 pm »
yep, that worked perfectly. thanks Egon.
The images you used for the flare in the benchmark app - have you made these available anywhere?

Support / Re: Lensflare help
« on: November 21, 2011, 03:31:00 pm »
I will try that tonight after work.. thanks :)

Support / Lensflare help
« on: November 19, 2011, 09:50:03 pm »
Im having trouble getting a simple lensflare to work and Im hoping somebody can help me since I must be missing something simple...

I initialize my flare when im setting up my world (adding objects, lightsources etc). I use the following line

flare = new LensFlare(sun.getPosition(), "test", "test", "test", "test");

Then in my method to render my scene, I am calling two different things on the lensflare

private void renderScene() {

      flare.update(frameBuffer, world);


I have added a texture called test to the texturemanager so I can just test this lensflare before i go worrying about using nice images.

I am however seeing nothing! The camera is always moving so thats why im calling update on the flare. The camera itself is always approximately 40 units away from the flare position and Im calling no other methods on the flare - just what you see above.

Any ideas?


Support / Re: transformVertices null pointer
« on: March 25, 2011, 01:26:50 pm »
sorry for not getting back on this sooner, have been pretty busy. I stopped making any changes to my world from the UI thread and now all works perfectly. Thanks again. I will add my game to project page sometime in next week or so.

Support / Re: transformVertices null pointer
« on: March 14, 2011, 10:37:41 am »
ah, yes I have been making small changes to the world in the actual android UI thread so this must be the issue as you stated. I will fix later. thanks for your help.

Support / transformVertices null pointer
« on: March 13, 2011, 02:41:37 am »
Hi, I'm currently getting a seemingly random intermittent null pointer exception at com.threed.jpct.Object3D.transformVertices( when Im attempting to render a scene. I can do the same thing a few times and this occurs sometimes but not most of the time. Have you any idea what the cause of this is or why the error seems to be random?


Projects / Re: My Project: Moleculary A PDB viewer.
« on: March 07, 2011, 02:36:01 pm »
Looks very cool

Support / Re: Getting started on JPCT-AE
« on: March 07, 2011, 02:23:50 pm »
I have to agree with kaiidyn on this one. I, for one, am glad that the examples are clear and to the point. Any MVC or multi-class structure would just detract from learning about the specifics of the jpct-ae library. It should not be hard to apply your imagination and coding experience to structure your application the way you want - its kind of assumed that if you realistically hope to write any application that you have the ability to at least do that much. Its not Egon's job to show you how to write java.

Support / Re: Menu System
« on: March 04, 2011, 01:40:15 pm »
and... done :)

Support / Re: Menu System
« on: March 04, 2011, 01:18:29 pm »
Hi Raft. Im now using your method for my menu system and its working out very well for me so thanks again for the suggestion.

Support / Re: Frame rate issue
« on: March 03, 2011, 02:26:20 pm »
Hey Egon, im looking at your Alien Runner source... great stuff! Seeing the source has answered a lot of the smaller questions I have been pondering too such as android lifecycle management and how to free up memory in better ways (i found my game crashes if i play it for too long). Many many thanks.

Support / Re: Frame rate issue
« on: March 03, 2011, 12:54:54 pm »
Thanks, I will take a look at that as well. Seems pretty simple now that I see the general approach :)

Support / Re: Frame rate issue
« on: March 03, 2011, 12:18:16 pm »
Thanks Kaiidyn, this is exactly what I needed to get me going.

Support / Re: Frame rate issue
« on: March 03, 2011, 11:24:33 am »
Thanks for the response. At the moment the gameplay is, unfortunately, coupled heavily with the frame rate. The game itself involves a character that is constantly running but the way im doing it is by translating the character by a certain amount on each draw frame. I couldnt really think about the best way to decouple the characters movement from the frame rendering. I will need to put some thought into the best way to do that.

Also, thanks for the suggestion of using the getters which take filler variables. At the moment I am working mostly off returned variables so I will change these later after work.

Im sure that my issue is being caused by my own current inexperience but I will hammer on and hopefully find a good way to decouple the translation of my avatar from the frame rate.


Pages: [1] 2