Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - mystara

Pages: [1] 2 3 ... 6
Projects / Re: AegisQuest
« on: January 03, 2010, 11:12:12 pm »
Yes, I thought it was a rather different approach than others had taken.

That said, there is a game element to our work - it's what produces the RPG interactions and so forth. It's just that our final product happens to be a video!

Projects / AegisQuest
« on: January 03, 2010, 04:16:47 pm »
We've been working on a project known as AegisQuest (, which is a live-action fantasy role playing "game" using the JPCT engine.

It combines full motion chromakey (blue screen) with recorded gameplay using a jpct client/server engine.

There's a trailer of our pilot production available here:

Projects / Re: Simple Animated Texture Interface
« on: December 15, 2009, 11:36:45 am »
I am very interested in this. I have a short (few seconds) looping movie that I'd like to use as a texture and this looks like exactly the right thing to use!

Can you give an indication as to its efficiency? Is there one format or way of encoding the animation that will keep the frame rate high? I'm trying to FRAPS the output at 30 fps, so I need it to be ultra efficient :D

Support / Re: Billboarding causing object to vanish?
« on: December 12, 2009, 03:26:43 pm »
Turns out both things were wrong.
Having set the rotation pivot and disabled culling, it works!

Support / Re: Unlit, clearly visible object
« on: December 12, 2009, 03:25:43 pm »

I don't suppose it's possible to make a particular object immune to fogging?

Support / Billboarding causing object to vanish?
« on: December 12, 2009, 12:36:16 pm »
Sorry, this is probably another noob question, but having looking through the javadocs, I cannot seem to find an explanation.

I created a new object (a rectangular plane) by:
Object rectangle = new Object(2);
rectangle.addTriangle(blah); rectangle.addTriangle(blah);

This works fine and I've been able to create a simple rectangle and colour it or apply to a texture to it.

I wanted to use billboarding so that the rectangle would always appear as a rectangle, regardless of the camera angle. However, when I try rectangle.setBillboarding(Object3D.BILLBOARDING_ENABLED) the model disappears.


Support / Re: Unlit, clearly visible object
« on: December 12, 2009, 12:33:30 pm »
hrm, almost.
The object becomes darker/fainter if the camera is further away. Not just smaller, but less well lit.

I don't really want to fiddle with my Config. settings, if I can avoid it. But I would suspect these are the cause? If so, is there a way to override them for a single object?

Current config is:
Config.fadeoutLight = true;
Config.linearDiv = 25;
Config.lightDiscardDistance = -1;
Config.farPlane = 1000;
Config.collideOffset = 250;

Support / Unlit, clearly visible object
« on: December 11, 2009, 12:42:55 pm »

Doubtless this is a silly question, but I'm not sure of the answer.

I'm trying to create a plane which is fully lit and yet does not light other objects. Specifically, I want the plane to be consistently lit no matter where the camera is. But I don't want it to create any light (so other nearby objects will not be illuminated) and don't want it to be affected by other light sources.

I think the way to do this is to set an additionalColor to the plane and to set the lighting mode to LIGHTING_NO_LIGHTS.

Is this correct?

Bugs / Re: Camera alignment error?
« on: September 28, 2009, 09:54:27 am »
That seemed to fix the problem.

Out of curiosity, is there any significant difference in efficiency between:





Bugs / Re: Camera alignment error?
« on: September 27, 2009, 08:26:39 pm »
Does this version also incorporate the fix from:,1427.0.html ?

Bugs / Camera alignment error?
« on: September 27, 2009, 10:07:47 am »

I've been experiencing a weird effect when I do:
Code: [Select]

In one particular case, it seems to cause the light level of my world to dramatically fall. Objects don't appear unless the camera is pointed directly at them and is close up. For example, the following screenshot occurs by carrying out the camera alignment (above):

If I manually reset and rotate the camera in this way:
Code: [Select]

The shot appears (correctly) like this:

Obviously I've resolved my problem by finding another way to do what I wanted to achieve, so it's not urgent.
But I thought someone here might like to know on the off chance that it's a bug in jpct. I cannot understand how aligning the camera would affect the light levels. But since that's the only line of code I'm changing, I can't see what else it would be.

Support / Re: 3DS Animated Model Error
« on: August 30, 2009, 04:19:07 pm »
I could not find any definitive forum posts validating this for certain - you can use a single 3DS file for your animations just like an MD2.  Works exactly the same.  You could surely export it frame by frame but you don't need to.  Is there some advantage or something?  I like the single file thing because it is consistent with the MD2 approach. 

To export the single 3DS file: 
1.  Tools->Snapshot...
     select 0 - 30 and 30 copies (for the model above that is). 
2.  Edit->Select By->Name
     Select the items you want in the export file - for me it was "monster01", "monster04"..."monster28".  Every 3rd
     frame resulting in a 10 frame animation sequence.  Hit the Select Button before leaving!
3.  File->Export Selected

I've found this guide very useful.
But does anyone know if there is a way to repeat the same process in blender?

i.e. given an animated model, how to export all frames of the model as a set of objects inside a single 3ds file.


Bugs / Re: World.toXML() error
« on: August 30, 2009, 04:17:09 pm »
That seems to have fixed the problem.

Bugs / Re: World.toXML() error
« on: August 27, 2009, 03:22:56 pm »
I should also add that the triangles themselves are ALSO present. It's literally that one tag which is missing.

Bugs / Re: World.toXML() error
« on: August 27, 2009, 02:37:48 pm »
No, not compiled or stripped.

Also, it's only the tag "<triangle_list>" which is missing. The closing tag ("</triangle_list>") is present.

Pages: [1] 2 3 ... 6